PBXes » English » Terminal Equipment » Need Sipura SPA 2102 Setting with ATT Uverse router
Print Page | Recommend to Friend | Add Thread to Favorites
Post New Thread Post Reply
Author
Post « Previous Thread | Next Thread »
tjs


Registration Date: 01.01.1970
Posts:

Need Sipura SPA 2102 Setting with ATT Uverse router Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

I swtiched from comcast to ATT Uverse and now the call drop after 5-6 minutes. I am using SIPURA SPA 2102 and my voip provider is future9.com for local calls and voipdiscount for international calls.

I am forwarding the port 5060 to my device IP address 192.168.1.101. The device is set to DHCP but I am using the router to reserve this address. I looked for configuration guide for SPA 2102 in the forum, but failed to find it.

Can you help?

I saw in system log:
NOTICE[8998] chan_sip.c: Disconnecting call 'SIP/tjsingh-201-cded' for lack of RTP activity in 61 seconds

Not sure if this message is useful.

05.02.2013 06:05 tjsingh is offline Search for Posts by tjsingh Add tjsingh to your Buddy List
tel
Premium Account


Registration Date: 28.07.2008
Posts: 239

RE: Need Sipura SPA 2102 Setting with ATT Uverse router Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Hi,
All SPA units use the same basic network and sip settings and these defaults generally work well. I always factory reset them and load the newest firmware before adding the local customisation (dial tones etc). I have never found port forwarding necessary (except the web interface if you want to remotely log in).
Regards

05.02.2013 13:59 telagente00 is offline Search for Posts by telagente00 Add telagente00 to your Buddy List
tjs


Registration Date: 01.01.1970
Posts:

RE: Need Sipura SPA 2102 Setting with ATT Uverse router Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Thanks Tel!! I would give it a shot. I am also using Cisco PAP2T on another line and have similar issue. Should I try setting it to factory default also or does it need special network configuration? It is bit surprising that the I need to change the settings after switching the internet provider. It would nice to be able to debug just in case the problem persists.

11.02.2013 22:33 tjsingh is offline Search for Posts by tjsingh Add tjsingh to your Buddy List
tel
Premium Account


Registration Date: 28.07.2008
Posts: 239

RE: Need Sipura SPA 2102 Setting with ATT Uverse router Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Hi,
I normally factory reset any new (or used) SPA or PAP2 just to make sure no one has played with the settings before I bought it. The PAP2 and SPA setup is virtually the same for the basic settings, which would normally remain the same for different ISPs.
Sounds like your router and ISP should be carefully checked out.
Regards

12.02.2013 01:30 telagente00 is offline Search for Posts by telagente00 Add telagente00 to your Buddy List
tjs


Registration Date: 01.01.1970
Posts:

RE: Need Sipura SPA 2102 Setting with ATT Uverse router Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Hi Tel,
After resetting the SPA 2102 and PAP2T, problem was still there. I stumbled upon this post:

http://www.toao.net/25-linksys-ata-configuration

and the only change I made after the factory reset was
>>As we planned to place our device behind a router, we turned on NAT Mapping and NAT Keep Alive.

(I also changed SIP T1 to 1 and Reg Retry Long Intvl to 120. but I don't think it is related to dropped calls.)

I didn't mess with other NAT support parameters yet, which are No by default.. I have come across posts which talk about setting some of these parameters to Yes when NAT Mapping is enabled.

NAT Support Parameters
Handle VIA received: Handle VIA rport:
Insert VIA received: Insert VIA rport:
Substitute VIA Addr: Send Resp To Src Port:
STUN Enable: STUN Test Enable:

I was able to make outgoing local call (which uses future9 voip) that did not drop even after 15 minutes. Earlier it used to drop after 9-10 minutes. I will keep my finger crossed and see if it holds for incoming (future9 voip) and international calls (voipdiscount voip)

I also found that Future 9 also recommended NAT Mapping Enable:
http://www.future-nine.com/faq/content/1...spa-device.html

Will keep you posted.

Thanks for your support.

Regards.

12.02.2013 13:22 tjsingh is offline Search for Posts by tjsingh Add tjsingh to your Buddy List
tel
Premium Account


Registration Date: 28.07.2008
Posts: 239

RE: Need Sipura SPA 2102 Setting with ATT Uverse router Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Hi,
Yes, I forgot the RTP Packet Size: 0.020, that should always be set (it affects the audio quality).

Register expires 300, SPA and PBXes will notice more quickly and attempt re register when poor broadband causes registration problems. Can go as low as 60 if necessary.

T1 Timer: 1, Reg Retry Long Intvl: 120 - Helps keep registration for networks with high latency (delay) like satellite links but will do no harm anyway.

I found that stun on/off, nat on/off and other nat support advanced parameters never made any difference to any of my remote SPAs ( different countries, different routers, different ISPs).

I will be interested if you find the exact setting that makes a difference with your router/ISP combination.

Regards

12.02.2013 17:00 telagente00 is offline Search for Posts by telagente00 Add telagente00 to your Buddy List
tjs


Registration Date: 01.01.1970
Posts:

RE: Need Sipura SPA 2102 Setting with ATT Uverse router Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

I made two outgoing US calls that dropped after 15 minutes and 29 minutes respectively. The battle is far from over. Need to find a way to debug this. Will contact future9 to see if they can help. PBX status log shows:

NOTICE[87791] chan_sip.c: Disconnecting call 'SIP/tjsingh-201-d87b' for lack of RTP activity in 61 seconds

13.02.2013 02:05 tjsingh is offline Search for Posts by tjsingh Add tjsingh to your Buddy List
tel
Premium Account


Registration Date: 28.07.2008
Posts: 239

RE: Need Sipura SPA 2102 Setting with ATT Uverse router Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

As a matter of interest does your SPA/ PAP2 hold registration ok. If you set the registration interval down to 60 secs you can check the PBXes log each day (there is no entry when it loses registration, only when it re registers). As a general idea most of my SPAs will re register maybe once per day. This would indicate a decent domestic broadband performance.
You could also try registering your SPA/PAP2 directly to your voip provider (removing PBXes from the loop) just to see if that affects things.

13.02.2013 13:04 telagente00 is offline Search for Posts by telagente00 Add telagente00 to your Buddy List
tjs


Registration Date: 01.01.1970
Posts:

RE: Need Sipura SPA 2102 Setting with ATT Uverse router Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Looking at my log:
Feb 14 00:06:26 VERBOSE[87791] logger.c: -- Registered SIP 'tjsingh-201' expires 300
Feb 15 00:18:20 VERBOSE[87791] logger.c: -- Registered SIP 'tjsingh-201' expires 300

It does seem that it is registering one per day. I have now set the registration interval to 60 sec.

I have a parallel discussion at ATT Uverse Forum:
http://forums.att.com/t5/Features-and-Ho...all/m-p/3426287

There was interesting following comment. It is to be seen if that makes a difference. I will keep you posted. Thanks for your continued interest.

I located this about port 5060:

"The U-Verse service requires the customer to use a router that was designed specifically for U-Verse Internet, TV, and phone service. This router has a default setting called SIP-ALG that cannot be disabled and the router cannot be replaced while using U-Verse internet. SIP-ALG is a router function that will cause VoIP traffic to be rewritten, which can cause problems such as one way audio, dropped calls, and inbound and outbound call failure. If you are familiar with making changes to your voice over IP phone/device, you will want to modify the source port of the phone to a port other than 5060 and reboot the U-Verse router."

15.02.2013 10:48 tjsingh is offline Search for Posts by tjsingh Add tjsingh to your Buddy List
tel
Premium Account


Registration Date: 28.07.2008
Posts: 239

RE: Need Sipura SPA 2102 Setting with ATT Uverse router Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Interesting about U-verse and its router as Its often recomended to disable Sip alg . It is sometimes found on the router setup pages or as a Telnet command.
You could change the Sip port on the SPA or PAP2 (to 5080 for example) and reboot everything, Its easy enough to try.
I have an Orange adsl service with Livebox router and phone in France which works quite happily without conflict with my SPA3102 and PBXes.
Regards

15.02.2013 15:21 telagente00 is offline Search for Posts by telagente00 Add telagente00 to your Buddy List
tjs


Registration Date: 01.01.1970
Posts:

RE: Need Sipura SPA 2102 Setting with ATT Uverse router Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

I have changed the SIP port. Would know how it impact over next week usage. of my phone.

I was using two PlugLink 9650 ethernet adapters (they plug to power outlets and have ethernet port) to provide internet connection to my Cisco SPA 3102. My residential gateway was in one room and ATAs in different room. AT&T technician pointed out that I would be getting only 1.5Mbps speed from these adapters while my residential gateway is giving 12Mpbs. I was able to install a repeater bridge (flashing dd-wrt to wrt54g) to provide close to 8Mpbs to the ATAs. I am not seeing the call drop after this.

This post has been edited 1 time(s), it was last edited by tjs on 01.04.2013 at 20:47.

19.02.2013 08:43 tjsingh is offline Search for Posts by tjsingh Add tjsingh to your Buddy List
 
Post New Thread Post Reply
Go to:

Powered by Burning Board Lite 1.0.2 © 2001-2004 WoltLab GmbH
English Translation by Satelk