PBXes » English » Terminal Equipment » No dial-out on Raspberry PI3 registered to PBXes.org
Print Page | Recommend to Friend | Add Thread to Favorites
Post New Thread Post Reply
Author
Post « Previous Thread | Next Thread »
gam
Grünschnabel


Registration Date: 14.10.2018
Posts: 6

Fragezeichen No dial-out on Raspberry PI3 registered to PBXes.org Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Hi,
I'm using IncrediblePBX for Raspberry PI (Asterisk 13.22.) It works properly with all providers.

I created a PBXes.org trunk to Google Voice and it registers alright. Also, the IncrediblePBX trunk to PBXes.org registers fine. The extensions, incoming, outgoing routes are properly defined on both systems. Incoming calls work fine.

On outgoing calls I get a ~20 seconds delay followed by the message "The number is not answering" and fast busy. It looks like the call reaches PBXes.org but there is no reply (see below.)

-- Executing [s@macro-dialout-trunk:25] Dial("SIP/901-00000002", "SIP/pbxes/18883455510,300,T") in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
-- Called SIP/pbxes/18883455510
[2018-11-01 13:17:12] WARNING[3878]: chan_sip.c:4069 retrans_pkt: Retransmission timeout reached on transmission 5c1cd1324118523d5201f47f26e47f73@x.x.x.x:5060 for seqno 103 (Critical Request) -- See https://wiki.asterisk.org/wiki/display/A...Retransmissions
Packet timed out after 19968ms with no response
[2018-11-01 13:17:12] WARNING[3878]: chan_sip.c:4093 retrans_pkt: Hanging up call 5c1cd1324118523d5201f47f26e47f73@x.x.x.x:5060 - no reply to our critical packet (see https://wiki.asterisk.org/wiki/display/A...Retransmissions).
== Everyone is busy/congested at this time (1:0/0/1)
-- Executing [s@macro-dialout-trunk:26] NoOp("SIP/901-00000002", "Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 18") in new stack
-- Executing [s@macro-dialout-trunk:27] GotoIf("SIP/901-00000002", "0?continue,1:s-CHANUNAVAIL,1") in new stack
-- Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
-- Executing [s-CHANUNAVAIL@macro-dialout-trunk:1] Set("SIP/901-00000002", "RC=18") in new stack
-- Executing [s-CHANUNAVAIL@macro-dialout-trunk:2] Goto("SIP/901-00000002", "18,1") in new stack
-- Goto (macro-dialout-trunk,18,1)
-- Executing [18@macro-dialout-trunk:1] Goto("SIP/901-00000002", "s-NOANSWER,1") in new stack
-- Goto (macro-dialout-trunk,s-NOANSWER,1)
-- Executing [s-NOANSWER@macro-dialout-trunk:1] NoOp("SIP/901-00000002", "Dial failed due to trunk reporting NOANSWER - giving up") in new stack
-- Executing [s-NOANSWER@macro-dialout-trunk:2] Progress("SIP/901-00000002", "") in new stack
-- Executing [s-NOANSWER@macro-dialout-trunk:3] Playback("SIP/901-00000002", "number-not-answering,noanswer") in new stack
-- <SIP/901-00000002> Playing 'number-not-answering.ulaw' (language 'en')
> 0x2c76780 -- Strict RTP switching to RTP target address 192.168.x.x:5020 as source
> 0x2c76780 -- Strict RTP learning complete - Locking on source address 192.168.x.x:5020
-- Executing [s-NOANSWER@macro-dialout-trunk:4] Congestion("SIP/901-00000002", "20") in new stack
[2018-11-01 13:17:14] WARNING[5096][C-00000001]: channel.c:5080 ast_prod: Prodding channel 'SIP/901-00000002' failed
== Spawn extension (macro-dialout-trunk, s-NOANSWER, 4) exited non-zero on 'SIP/901-00000002' in macro 'dialout-trunk'
== Spawn extension (from-internal, 18883455510, 6) exited non-zero on 'SIP/901-00000002'
-- Executing [h@from-internal:1] Macro("SIP/901-00000002", "hangupcall") in new stack
-- Executing [s@macro-hangupcall:1] GotoIf("SIP/901-00000002", "1?theend") in new stack
-- Goto (macro-hangupcall,s,3)
-- Executing [s@macro-hangupcall:3] ExecIf("SIP/901-00000002", "0?Set(CDR(recordingfile)=)") in new stack
-- Executing [s@macro-hangupcall:4] Hangup("SIP/901-00000002", "") in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on 'SIP/901-00000002' in macro 'hangupcall'
== Spawn extension (from-internal, h, 1) exited non-zero on 'SIP/901-00000002'

The error showing on phone system is: "503 VoIP status code: 0x503 The server is temporarily unable to process the request due to a temporary overloading or maintenance of the server." However, I can dial out through PBXes on the same Google Voice trunk from other extensions, not through the PI3 though.

I do not have firewall or NAT issues with any other providers' (voip.ms, v1voip, TCXC etc.) trunks installed on the same Raspberry PI3+, except for PBXes.org.

Another test that worked well is connecting the Gigagset phone system (on the same network) directly to PBXes.org - that works well, too.

I'd like though to have this working on the PI3 for all the evident reasons. Any suggestions?

07.11.2018 00:07 gamet is offline Search for Posts by gamet Add gamet to your Buddy List
i-p
Super Moderator


Registration Date: 14.01.2006
Posts: 4476

RE: No dial-out on Raspberry PI3 registered to PBXes.org Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

You should enable a SIP Trace on your RasPi.

08.11.2018 12:57 i-p-tel is offline Search for Posts by i-p-tel Add i-p-tel to your Buddy List
gam
Grünschnabel


Registration Date: 14.10.2018
Posts: 6

RE: No dial-out on Raspberry PI3 registered to PBXes.org Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

I just looked over the trace - for some reason, the registration from RasPI to PBXes.org works fine. However, when dialing out I get a "SIP/2.0 401 Unauthorized" in the trace. I removed the password both in RasPI and PBXes extension, registration works, dial-out works.

So, it works without a password, but when adding one it stops dialing-out. That's what I have in "Peer details":

type=peer
secret=<empty>
qualify=yes
nat=yes
insecure=port,invite
host=pbxes.org
fromuser=xxxxx-xxx
dtmfmode=rfc2833
dtmf=rfc2833
disallow=all
defaultuser=xxxxxx-xxx
context=from-trunk
canreinvite=yes
authuser=xxxxxx-xxx
allow=ulaw

...and "Register string":
xxxxxx-xxx:<empty>@pbxes.org/NXXNXXXXXX

And BTW everything works fine over a chan_pjsip trunk from RasPI to PBXes (including password.) I would prefer to use chan_sip once the password (lack thereof) is resolved


Any suggestions please?

This post has been edited 3 time(s), it was last edited by gam on 08.11.2018 at 20:15.

08.11.2018 15:05 gamet is offline Search for Posts by gamet Add gamet to your Buddy List
i-p
Super Moderator


Registration Date: 14.01.2006
Posts: 4476

RE: No dial-out on Raspberry PI3 registered to PBXes.org Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Please include your SIP Trace. An Unauthorized response is normal. It usually gets followed by another INVITE.

09.11.2018 10:01 i-p-tel is offline Search for Posts by i-p-tel Add i-p-tel to your Buddy List
gam
Grünschnabel


Registration Date: 14.10.2018
Posts: 6

RE: No dial-out on Raspberry PI3 registered to PBXes.org Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Agreed, and the password should be provided upon that next invite.

How can I upload the SIP trace to you? If I paste it in it takes more than 3 posts (and it strictly covers one attempted dial-out...) and it contains all that private information...

10.11.2018 02:08 gamet is offline Search for Posts by gamet Add gamet to your Buddy List
i-p
Super Moderator


Registration Date: 14.01.2006
Posts: 4476

RE: No dial-out on Raspberry PI3 registered to PBXes.org Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Send it by email to presse@i-p-tel.com, please.

11.11.2018 00:38 i-p-tel is offline Search for Posts by i-p-tel Add i-p-tel to your Buddy List
i-p
Super Moderator


Registration Date: 14.01.2006
Posts: 4476

RE: No dial-out on Raspberry PI3 registered to PBXes.org Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Thanks, we have received your log.

When you use chan_sip your INVITE message gets too long, exceeding maximum packet length on UDP. You can either switch to TCP or reduce packet length by adding "icesupport=no" to your sip.conf.

12.11.2018 11:31 i-p-tel is offline Search for Posts by i-p-tel Add i-p-tel to your Buddy List
gam
Grünschnabel


Registration Date: 14.10.2018
Posts: 6

RE: No dial-out on Raspberry PI3 registered to PBXes.org Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Thank you for the magic...

Outbound calls go through now on the chan_sip trunk (with the password set on the extension.)

12.11.2018 23:54 gamet is offline Search for Posts by gamet Add gamet to your Buddy List
 
Post New Thread Post Reply
Go to:

Powered by Burning Board Lite 1.0.2 © 2001-2004 WoltLab GmbH
English Translation by Satelk