PBXes » English » Miscellaneous » Problem with classic extensions in ring groups
Print Page | Recommend to Friend | Add Thread to Favorites
Post New Thread Post Reply
Author
Post « Previous Thread | Next Thread »
hol
Premium Account


Registration Date: 10.05.2018
Posts: 22

Problem with classic extensions in ring groups Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Our incoming calls go to a ring group 100 - calling all of 4 office extensions.

If not answered it goes to another group (150), but if this group includes classic extensions (ring all or hunt) the group is skipped and it goes straight to the next stage.

I can call ring group 150 from an extension and it works fine. I have checked and double checked there are no rogue extensions in any ring groups, so am puzzled as to why this is failing.

I have also found that if I select a classic extension if unanswered that also fails.

Scanning through the forum I can see some similar issues back in 2013, but I assume this is not a common problem.

Any ideas?

This post has been edited 1 time(s), it was last edited by hol on 15.08.2018 at 17:53.

15.08.2018 17:53 holbrook is offline Search for Posts by holbrook Add holbrook to your Buddy List
i-p
Super Moderator


Registration Date: 14.01.2006
Posts: 4509

RE: Problem with classic extensions in ring groups Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Ring groups allow adding a '#' after a phone number within the extension list. Have you tried that instead of going thru a classic extension?

15.08.2018 21:28 i-p-tel is offline Search for Posts by i-p-tel Add i-p-tel to your Buddy List
hol
Premium Account


Registration Date: 10.05.2018
Posts: 22

RE: Problem with classic extensions in ring groups Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

I have tried that, but it is still skipping this stage.

I am using the local phone umber format (e.g. 07811111111# ) but it is not working

2018-09-07 Update:
I found I could get the routing to work if I defined a Default outbound route. It looks like the routing logic is not respecting the Ext rules set up (I have mine in blocks of 100 for different companies/departments in a building). Even though the secondary ring group is in the range for the pattern match, it is not being matched.

So, a default route picks it up and sends the calls on - either to Classic extensions or numbers listed. This is not ideal, as only 1 outgoing line is used for different companies in the building.

Also, on routing to an outside number, the original caller ID is lost and replaced with the outgoing line's caller id. Is this something PBXes is doing or my SIP trunk provider?

This post has been edited 1 time(s), it was last edited by hol on 07.09.2018 at 14:20.

16.08.2018 11:57 holbrook is offline Search for Posts by holbrook Add holbrook to your Buddy List
i-p
Super Moderator


Registration Date: 14.01.2006
Posts: 4509

RE: Problem with classic extensions in ring groups Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

Yes, that makes sense because the outbound route is picked based on the caller's ID when forwarding calls. Your SIP provider replaces this ID. If you use one preserving it you will be able to fully solve the issue.

10.09.2018 07:17 i-p-tel is offline Search for Posts by i-p-tel Add i-p-tel to your Buddy List
hol
Premium Account


Registration Date: 10.05.2018
Posts: 22

RE: Problem with classic extensions in ring groups Post Reply with Quote Edit/Delete Post Report Post to a Moderator       IP Information Go to the top of this page

OK. Before I request the trunk provider to turn off the forced caller ID do I need to do anything in PBXes to make sure the normal outgoing calls have the right caller IDs on them?

10.09.2018 10:57 holbrook is offline Search for Posts by holbrook Add holbrook to your Buddy List
 
Post New Thread Post Reply
Go to:

Powered by Burning Board Lite 1.0.2 © 2001-2004 WoltLab GmbH
English Translation by Satelk